閉じる Support & Service
FAQ
文書番号
-------
最終UpDate
2005/2/10
Products
Dr.SumEA
Dr.SumEA Synchronizer for Oracle(R) database
Dr.SumEA ReportingServer
Version
Dr.SumEA Ver.2.2までの全てのバージョン
Dr.SumEA Synchronizer for Oracle(R) database Ver.1.0
Dr.SumEA ReportingServer Ver.1.0
Platform
Windows
Dr.Sum EAに関する重要なお知らせ
問題点・注意点・制限事項
以下の何れかの条件に該当する稼動環境においてのみ障害が発生する可能性があります。
一つのテーブル内のカラム数が50以上でかつレコード件数が100万件以上
データベースを構成するCRXファイルのサイズが128MB以上でかつ[データベース]−[プロパティ]のCRXメモリサイズの設定の内「ダイナミック」の値が128MB以下
データーベース内の全てのテーブルの削除済みも含むレコード数の合計が3000万レコード以上でかつ削除済みレコードが2000万件以上の状態でガベージコレクション(最適化)を行った場合

当該障害により、ユーザー様の運用に支障をきたすおそれがあります。
上記条件に該当するお客様は下記の「ウイングアークテクノロジーズお問い合わせ窓口」までご連絡下さい。
データベースの集計結果やデータの値が不正となるまたは、テーブルへのアクセスができなくなります。

<<緊急のお願い事項>>
運用状況のことを考慮して緊急にデータベースのバックアップをお取り下さい。
※可能であれば、バージョンアップまでの間、毎日データベースのバックアップをお願いします。
(→バックアップ手順は、Dr.SumEA ユーザーズ・マニュアル サーバ編「Enterprise Manager」の「データーベース」の「データーベースに関する操作」の「データーベースのバックアップ」の項をご覧下さい。)
原因
調査の結果、以下の誤りがあり障害が発生していました。
データベース内の空き領域の管理に誤りがあり、特定の条件において、既に他のテーブルに割り当て済みの領域を空き領域として割り当ててしまい、他のテーブルのデータが上書きを行っていました。
共有メモリのページ管理に誤りがあり、ダイナミックに拡張したメモリ領域を開放した後も、そのメモリ領域を参照していました。
データベースの最適化(ガベージコレクション)の処理の中で、データベースの領域の管理に誤りがあり、最後のブロックを不正に開放していました。
テーブルをインポートした際に、ROWID管理に誤りがあり、実際の行件数より多い値を最終のROWID値としてセットしていました。
データベースに対し、Insert、Update、Deleteおよび追加インポート処理中にメモリ障害による内部エラー発生時の仕様に不備があり、バックアウトせずに、不正な状態を共有メモリ内に保持してしまっていたため、後続の処理でデータベースに反映していました。
テーブル削除中にエラーが発生した場合の仕様の不備があり、テーブルの削除処理が中途半端な状態で終了していました。
以上の障害の原因となっていました誤りを修正いたしました。
既にご案内させていただいておりますようにDr.SumEA Ver2.2aで障害対応を行います。
解決方法
<Dr.SumEAをお使いの全てのお客様>
・ 障害対処済みのDr.SumEA Ver.2.2aへの無償バージョンアップ(→2/7以降適用可能)
<Dr.SumEA Synchronizer for Oracle(R) database Ver.1.0をお使いのお客様のみ>
・Dr.SumEA Synchronizer for Oracle(R) database Ver.1.1への無償バージョンアップ
(→上記対応タイミングと同時に適用
→今回の障害の直接の原因ではないですが、Dr.SumEAが2.2aにバージョンアップする際に同期を取る必要があるため)
<Dr.SumEA ReportingServer Ver.1.0をお使いのお客様のみ>
・Dr.SumEA ReportingServer Ver.1.1への無償バージョンアップ
(→上記対応タイミングと同時に適用
→今回の障害の直接の原因ではないですが、Dr.SumEAが2.2aにバージョンアップする際に同期を取る必要があるため)
製品提供時期
対象製品(Dr.SumEA Ver.2.2a、Dr.SumEA Synchronizer for Oracle(R) database Ver.1.1、Dr.SumEA ReportingServer Ver.1.1)
現在、全て提供しております。対象のお客様は、下記「お問合せ窓口」よりご連絡下さい。
補足事項・関連情報
お問合せ窓口(瑕疵の問題に対するお問い合わせ (ご購入後6ヶ月以内に限ります))
URL:https://www.wingarc-support.com/user/defect/index.html
※入力フォーム「製品の現象」のはじめに 「<DrSUM EA 2月10日重要なお知らせの件>」 と入力下さい。
参照ファイル
特に無し。
法律上の注意事項と商標について
Copyright(C) 2004-2008 WingArc Technologies, Inc. All rights reserved